ELSAG NORTH AMERICA

LPR CarSystem Software Update - Windows XP

Microsoft ended its XP support on April 8th- Here’s an opportunity to upgrade your ELSAG LPR CarSystem Software!

Now that Microsoft has ended its support of XP, users who continue to operate this platform will be vulnerable to security breaches.  When Microsoft releases security updates/fixes for Windows 7 and Windows 8, it is by default identifying weaknesses in their operating systems like XP that could be inappropriately taken advantage of.  Specifically, ELSAG users who continue to use XP will see issues that will affect the PC performance and security, which will make our system unusable.  

Further, viruses and Trojans could be used as a platform to attack your internal network and servers if security updates are not current (the availability of which ended when Microsoft stopped supporting XP).  Additionally, any customers who have fixed or covert systems with FCU’s or brick computers need to consider the vulnerability not upgrading to Widows 7 or 8 poses to their network.  Even under an ELSAG maintenance/warranty program, ELSAG is not responsible for the operating system upgrades. To maintain the integrity and security of your operating system, ELSAG strongly recommends that you upgrade from XP to a minimum of Windows 7.

When upgrading your Windows Operating System, use this opportunity to upgrade your ELSAG software to the most powerful and secure LPR system software to be developed with the power of the ELSAG Operations Center (EOC).  

EOC 5 and CarSystem 6 utilize up to date encryption technology to protect data communication. The system communications can be protected in two ways: 

  • Since the EOC 5 is a web application the communication between the browser (client) and the web server can be protected with the HTTPS protocol and SSL/TLS technology.   
  • CarSystem to EOC communication. Each LPR mobile unit or fixed control unit (FCU) communicates with the central server exchanging data such as reads and Hot Lists. This communication can be secured via TSL encryption. In this way it will be impossible to intercept and understand the content of the messages exchanged within the system via public Internet.  Also any message received by either component (server or car MDT/FCU) will be accepted only if the identity of the sender is authenticated. This makes a successful hacker attack to the LPR infrastructure very unlikely.

 
Either one or both methods can be implemented in any LPR systems.  X.509 certificates issued by CA (Certificate Authority) or user self-signed certificates can be used for both purposes.

Features of the new CarSystem:  

  
CLIENT NOTICE 

  • More intuitive user interface
  • Greater Hot List Flexibility
  • Expanded mapping
  • Officer’s note field for capturing real-time information
  • Pending alarm view
  • Enhanced reporting
  • Image zoom capabilities

 
Features of the new EOC:

  • A simple GUI design through a secured web base
  • Easy to use with “Google” style entry and speed
  • Permissions at domain, group and user levels
  • Audit trails for visibility of data sets and use of the system
  • Mapping with street locations
  • Hotlist manager to limit visibility of specific lists
  • Simplified approach to adding additional cameras
  • Enhanced reporting
  • Authentication using active directory
  • Built to accept data from other external sources

Are you upgrading from Windows XP but want to continue using an ELSAG legacy software product? 

Customers moving from XP to Windows 7 or Windows 8 will require an ELSAG CarSystem upgrade to CS 5.10 to be compatible with the new operating systems. ELSAG will provide the latest version of the previous version of CarSystem, CS 5.10 software and installation instructions at no cost to agencies for self-installations.  For agencies requiring installation support, ELSAG will provide remote installation for $312.50 per system.  
 
Clients who continue to use XP will be offered limited support on hardware only.  Our support group will diagnose problems and manage all hardware issues accordingly. However, it the diagnosis is related to an XP security or software compatibility issue, we will not be able to provide continued support as any future released or patched of CarSystem or EOC will not be tested and guaranteed for XP. ELSAG is not responsible for any issued related to XP security vulnerabilities that may affect CarSystem or EOC.  We strongly recommend that clients upgrade their operating system to Windows 7 or 8 to ensure they are receiving the security updates from Microsoft. 

 

 

Loading

Loading

Loading

Loading

Loading

Loading

Loading

Loading

Loading

Loading